Fem例程运行问题

[Taichi] version 0.8.8, llvm 10.0.0, commit 7bae9c77, win, python 3.8.10

D:\chengxu\python\python.exe: can't open file 'fem-explicit.py': [Errno 2] No such file or directory
Running time: 0.04s
PS F:\project\taichi> python -m taichi F:\project\taichi\--Deformables-master\fem-explicit.py
[Taichi] version 0.8.8, llvm 10.0.0, commit 7bae9c77, win, python 3.8.10

*******************************************
**      Taichi Programming Language      **
*******************************************

[Taichi] version 0.8.8, llvm 10.0.0, commit 7bae9c77, win, python 3.8.10
[Taichi] Starting on arch=x64
[E 12/24/21 20:37:53.025 8708] [D:/a/taichi/taichi/taichi/util/image_buffer.cpp:write_text@120] Font file not found: D:\chengxu\python\Lib\site-packages\taichi\_lib\runtime/../assets/Go-Regular.ttf

Traceback (most recent call last):
  File "F:\project\taichi\--Deformables-master\fem-explicit.py", line 285, in <module>
    gui.text(
  File "D:\chengxu\python\lib\site-packages\taichi\ui\gui.py", line 606, in text
    self.canvas.text(content, pos, font_size, color)
RuntimeError: [D:/a/taichi/taichi/taichi/util/image_buffer.cpp:write_text@120] Font file not found: D:\chengxu\python\Lib\site-packages\taichi\_lib\runtime/../assets/Go-Regular.ttf

例程来自https://github.com/taichiCourse01/–Deformables
文件缺失Go-Regular.ttf,实际runtime下并没有其他文件夹

Hi @maplezip,非常欢迎你来到太极论坛。

你是已经下载了示例程序,安装了太极然后运行出错是么?

你可以到示例程序的文件夹(包含 fem-explicit.py 文件),然后直接打开命令行,再运行 python fem-explicit.py 试试么?

是的,cmd是同样的错误
[E 12/27/21 14:03:08.189 19428] [D:/a/taichi/taichi/taichi/util/image_buffer.cpp:write_text@120] Font file not found: D:\chengxu\python\Lib\site-packages\taichi_lib\runtime/…/assets/Go-Regular.ttf
基本例程比如implicit和main可以正常运行
只有fem和mess这两个不能运行,且报错都是这个
试过了把某些代码注释掉
gui.text(
content=f’9/0: (-/+) Young’s Modulus {YoungsModulus[None]:.1f}’, pos=(0.6, 0.9), color=0xFFFFFF)
gui.text(
content=f’7/8: (-/+) Poisson’s Ratio {PoissonsRatio[None]:.3f}’, pos=(0.6, 0.875), color=0xFFFFFF)
这两句出了问题

确定了,就是gui.text出现问题,删掉就能正常运行了。不知道是否是例程没有更新?

哦哦,明白了,这是之前版本更新导致的bug。
最新版本0.8.8里的PR应该就修复了这个Bug。

抱歉,我刚才试了一下,发现之前的PR并没有解决你的问题,重新提交了一个PR来修复这个Bug.