Is there a way to turn off the verbose?

The verbose is very convenient for me to debug taichi but it is not when I bug other parts of my code.

A partial solution for now is

import taichi as ti
ti.set_logging_level('error')
...

There are still some verbosity remaining, which I will fix in the next release.

Update: in v0.2.6 (will be released in 30 minutes), use

ti.get_runtime().set_verbose(False)

to shut off verbosity.

Thank you for shutting off verbosity, but now I have some problem turn on :sweat:.
Even if I use ti.get_runtime().set_verbose(True) in the beginning of my code, I still cannot see any verbosity.

This is weird… Could you email me the script to reproduce this?

Em…I just find this is caused by another problem, I have posted here Can't matrix be initialized without shape.